WordPress.org

Plugin Directory

WP Store Locator

An easy to use location management system that enables users to search for nearby physical stores.

Requires: 3.5 or higher
Compatible up to: 4.2
Last Updated: 2015-4-19
Active Installs: 8,000+

Ratings

4.9 out of 5 stars

Support

48 of 65 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
100,1,1
100,1,1
100,4,4
100,2,2 100,2,2
100,4,4
100,1,1
100,3,3
100,4,4 100,1,1