WP SlideYourNet

Description

SlideYourNet wrapper for WordPress

Insert a list of posts from social medias fetched by slideyour.net

The shortcode

Use the [syn] shortcode anywhere in your pages to display posts.

Parameters

Misc

  • title=”

Filters

  • network=” (empty, twitter or facebook)
  • username=”
  • search=”
  • ref=” (empty value for anything, “yes” for repost only or “no” for original post only)

Sortering

  • order_by=’pub_date’
  • order=’DESC’
  • per_page=5

Displaying

  • display_date=” (boolean)
  • display_username=” (boolean)
  • display_avatar=” (boolean)
  • display_media=” (boolean)
  • stylesheet=’wpsyn’ (“wpsyn” for default stylesheet or “theme” for the wpsyn.css file within your theme)

Example:

[syn per_page=20 display_media=1 display_date=1 display_username=1 display_avatar=1 ref=no]

Installation

  1. Upload the plugin folder to the /wp-content/plugins/ directory
  2. Activate the plugin through the ‘Plugins’ menu in WordPress admin

FAQ

Which social-medias are currently supported?

Actually, posts can only be fetched from twitter and facebook, but instagram is on the go

Is this plugin usable out of the box?

No, you have to create an instance on slideyour.net in order to fetch posts.
You’ll just have to connect your social media accounts.

Contributors & Developers

“WP SlideYourNet” is open source software. The following people have contributed to this plugin.

Contributors

“WP SlideYourNet” has been translated into 1 locale. Thank you to the translators for their contributions.

Translate “WP SlideYourNet” into your language.

Interested in development?

Browse the code, check out the SVN repository, or subscribe to the development log by RSS.

Changelog

2.2

  • Keep old datas when API do not respond quickly enough
  • Add setting for API timeout
  • Fix warning when new setting is not set

2.1

  • Privacy: add remote images proxy
  • Correct network setting escapment
  • Set noopener to blank links
  • Use img instead of div.background
  • Escape special chars. remove PHP warnings

2.0.0

  • Add shortcode support

1.0.0

Initial release