WordPress.org

Plugin Directory

WP Photo Sphere

A filter that displays 360-degree panoramas taken with Photo Sphere.

How to add a panorama?

Use the Add a panorama button to upload or choose a panorama to insert into your post.

How to change the dimensions?

By default, the dimensions are 560 x 315 pixels but you can change that in the options page (in the Settings menu).

You can also choose different dimensions for each panorama using the width and height attributes. For example: [sphere 42 width="200" height="400"] or [sphere 42 width="50%" height="300"].

A maximum width can also be given with the attribute max_width. Its default value can be changed in the options page.

How to display the navigation bar?

The navigation bar allows users to zoom, animate the panorama or view it in fullscreen. To display it, just use the navbar attribute with the value yes: [sphere 42 navbar="yes"].

You can choose to display it (or not) on all of your panoramas in the options page. If you display it on all of your panoramas and want to deactivate it on one particular panorama, use the navbar attribute with the value no.

Can I change the automatic animation?

By default, panoramas are automatically animated after 2000 milliseconds, but you can change this with the anim_after attribute. You can also deactivate the animation with the value -1. For example:

[sphere 42 anim_after="5000"]

or [sphere 42 anim_after="-1"].

You can set the animation speed with the anim_speed attribute. It accepts six units: revolutions per minute/second (rpm/rps), degrees per minute/second (dpm/dps) or radians per minute/second (rad per minute/second). The default speed can be set in the options page. Example: [sphere 42 anim_speed="10rpm"].

Is it possible to autoload the panorama?

Since the version 1.1, you can specify, for each panorama, a special attribute: autoload. If you use this attribute, the panorama will start automatically after the page has loaded. This attribute doesn't require any value, for example: [sphere 42 autoload] or [sphere 42 width="300" height="150" autoload].

Requires: 3.1 or higher
Compatible up to: 4.1.1
Last Updated: 2015-1-6
Active Installs: 600+

Ratings

3.8 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
0,1,0 100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
0,1,0 100,1,1
100,1,1 100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1