WordPress.org

Plugin Directory

WP Mass Delete

Allows one to mass delete WordPress posts and pages according to the specified conditions such as date range, post status, post content, etc.

2.1

  • The "Usage of wpdb::escape is obsolete from version 3.6" notice has been fixed.

2.0

  • Fixed CSRF vulnerability.
  • Fully compatible with WordPress 4.2.2.

1.8

  • Fully compatible with WordPress 4.1.1.

1.7

  • Fully compatible with WordPress 4.1.

1.6

  • Fully compatible with WordPress 4.0.1.

1.5

  • Fully compatible with WordPress 4.0.

1.4

  • Fully compatible with WordPress 3.6.1.

1.3

  • The "Type of items to delete" and "Post status" options are pre-checked now.

1.2

1.1

  • Improved compatibility with older versions of WordPress.

1.0

  • Initial release.

Requires: 2.0.0 or higher
Compatible up to: 4.2.3
Last Updated: 2015-7-9
Active Installs: 4,000+

Ratings

5 out of 5 stars

Support

2 of 2 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

1 person says it works.
0 people say it's broken.

100,1,1
100,1,1
100,1,1
100,1,1
100,1,1