WordPress.org

Ready to get started?Download WordPress

Plugin Directory

CopySafe Web Protection

Insert CopySafe Web encrypted images to copy protect all media in posts and pages from right-click-save, mouse-drag, Print Screen and screen capture.

1.7

  • Tested for compatibilty with WP 4.1.

1.6

  • Minor adjustment for WP 4

1.5

  • Tested and verified on WordPress version 4.0
  • Adjusted upload save form to better fit small screen sizes.

1.4

  • Tested and verified on WordPress version 3.9.2
  • Added alternative user check in case session logging not supported by webhost.
  • Added settings option to allow uploads by admin only.
  • Upload will progress only on same host IP.
  • Referrer user agent must be Shockwave Flash
  • Referrer url must match with the same script name.
  • Save settings page options altered for show in smaller screens.
  • No need to click "Insert File to editor" button after Save button clicked.

1.3

  • Added login requirements to upload functions.

1.2

  • Fixed security flaw in upload function.
  • Tested and aproved for WordPress 3.9.

1.1

  • Removed alert that displays image size.
  • Tested and aproved for WordPress 3.8.

1.0

  • Fixed detection bug for Internet Explorer 11 and Windows 8.1.

0.9

  • Added support for Windows 8.1
  • Plugin version incremented to 4.7.2.0
  • Tested and verified for WP 3.7.1

0.8

  • Added allowance for Firefox 20 and later.

0.7

  • Added option to manually set image width and height.
  • If image size is not set then the filename dimensions are used.

0.6

  • Removed dependency on wp-load.php.

0.5

  • Updated for JQuery 1.8

0.4

  • Clean up and clarified definitions used in settings.

0.3

  • Added Netscape Navigator browser option in default settings.
  • Fixed bug with progress bar displayed when uploading.

0.2

  • Added parameters to shorcode for editing of existing image inserts.
  • Same images can be used on multiple posts with unique settings.
  • Revised default settings options.
  • Revised functions to comply with CodePlex recommendations.

0.1

  • First release.

Requires: 3.0.1 or higher
Compatible up to: 4.1.1
Last Updated: 2014-12-17
Active Installs: 900+

Ratings

0 out of 5 stars

Support

1 of 1 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,2,2
100,1,1