Plugin Directory

WoW Armory Character

Pulls character information from the WoW community API and displays it.


  • Updated the wowhead tooltips to work with the new way of handling item ID's.


  • Allow the clearing of all the cached items. Possible fix for the issue with acheivements reported by SilverCha0s
  • Include Italian language configuration options.


  • Starting at the big 1.0. Is stable enough for that I reckon.
  • Tooltip updates to show item upgrades/reforges.
  • Reworked achievements to calculate based on API - not using a hardcoded value.
  • Fixed a large number of bugs
  • Styling tweaks to work better in Twenty Fourteen
  • The activity feed for your character can now be shown. This is just like the one from your armory page and shows the last 5 items, achievements and achievement criteria you gained. PLEASE NOTE: If you're upgrading to this release your widgets may give errors until their settings are adjusted.
  • Realms are now chosen from a dropdown list rather then typed. This should help where the slug varies from the realm name.
  • DEPRECATED setting for css inclusion. A filter is now available for theme authors.
  • Moved to grunt for building.
  • New banner!


  • Update for patch 5.0.4 talent changes.
  • Achievement count update
  • Include Portugese language configuration options.


  • New global settings introduced. Including the ability to disable the built in stylesheet and wowhead integration.
  • Professions now show.
  • Shoulder slot items now show correctly. Thanks to xsherbearx for reporting the issue.
  • Numerous other bug fixes and code cleanups.


  • Achievements are now available to be shown.
  • New filter added to allow you to change the template file location.


  • Fixed usages of DIR which is PHP5.3 only. The plugin should now work on PHP5.2+ Thanks to @Flavio_Torelli for reporting the issue.


  • Retagging since I messed it up. Give us a break it's my first plugin :)


  • Changed file address from FILE since it does not work well with symlinks
  • Enforced correct language choices per region
  • Fixed realms with spaces in their names
  • Fixed some images not working in a non-english locale
  • Added KR and TW regions


  • The initial release of the plugin.

Requires: 3.5.0 or higher
Compatible up to: 4.0.8
Last Updated: 2014-11-18
Active Installs: 300+


0 out of 5 stars


Got something to say? Need help?


Not enough data

0 people say it works.
0 people say it's broken.

100,1,1 100,1,1 100,2,2 100,2,2
100,1,1 100,1,1
100,1,1 100,1,1 100,1,1