WordPress.org

Plugin Directory

!This plugin hasn’t been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

WordPress Web Service

WordPress Web Service is used to access WordPress resources via WSDL and SOAP.

0.2.3

  • [FEATURE] You may now also query for categories (patch provided by Arman Safikhani - armansafikhani@hotmail.com)
  • [FIX] The integrated online SOAP client is replaced by http://wsdlbrowser.com
  • [FIX] Resolved Bug 16 ("strlen() expects parameter 1 to be string")
  • [BUG] getImages & getGalleries seem to be broken

0.2.2

  • Resolves potential security vulnerabilities in resize-image.php
  • Resolves potential security vulnerabilities in the web service (wpws-soap.php)

0.2.1

  • Change of namespace from *.wpws.bkahlert.com to *.wpws.develop.bkahlert.com
  • Issues with pages/posts that contain html entities and are processed by getGallery/getImages resolved
  • Issue with some WordPress installation that couldn't retrieve any SOAP response resolved (changed SOAP address from .../index.php/wpws to .../index.php?/wpws

0.2.0

  • Incompatibility with Flash Builder resolved
  • Compatibility with WordPress 3.x

0.1.4

  • A writeable cache directory is no more needed in order to dynamically resize images and to return the correct content length to the caller.
  • The resizeableUrl attribute of the Image datatype contains now 3 placeholders, namely %{WIDTH}, %{HEIGHT} and %{QUALITY}.
  • The Image type now contains the property parentId
  • Method getImages now allows to return not only images of one resource but also of all child resources

0.1.3

  • Properties width, height, maxResizeableWidth and maxResizeableHeight added to Image type
  • Minor bugs removed

0.1.2

0.1.1

  • Improved WSDL1.1 compability
  • WSDL file size optimization

0.1.0

  • Initial version

Requires: 2.8 or higher
Compatible up to: 3.6.1
Last Updated: 3 years ago
Active Installs: 500+

Ratings

0 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
0,1,0
100,1,1
0,1,0
0,1,0
0,1,0