WordPress.org

Plugin Directory

WooCommerce Pay for Payment

Setup individual charges for each payment method in woocommerce.

1.3.5

  • Fix: make it work with stripe for woocommerce by Stephen Zuniga

1.3.4

  • Code Refactoring: set plugin textdomain to plugin slug
  • Translations: Minor correction in espaƱol and german translations

1.3.3

  • Feature: Minimum and maximum charges.

1.3.2

  • Feature: Deactivate if WooCommerce version is below requirement.
  • Fix: Missing Taxes

1.3.1

  • Fix Admin: Payment gateway Class not found (may occur with 3rd party gateways)
  • Fix: textdomain loading
  • Update turkish localisation

1.3.0

  • Feature: Enhanced UI
  • Feature: Select tax class to be applied to payment fee
  • Feature: Select if cart taxes will be included on payment fee calculation
  • Feature: Placeholders in fee title.
  • Fixes: completely repeat all woocommerce tax and fee calculation steps after payment fee has been added.

1.2.5

  • Fix: incorrect fee calculation.

1.2.3

  • Fix: Safely Restrict payment fee to 2 Decimals.

1.2.2

  • Fix: Calculate taxes
  • Fix: cart contents taxes and shipping taxes included into fee calculation
  • Refactoring: Discard cart_has_fee() check, as it is already done by woocommerce

1.2.1

1.2.0

  • Feature: add option to disable payment fee when free shipping is selected
  • Feature: add pay4pay column in woocommerce checkout settings
  • Plugin-API: add filter woocommerce_pay4pay_apply
  • Code Refactoring: separated admin UI from frontend to keep things lean.
  • Code Refactoring: use function WC() (available since WC 2.1) in favour of global $woocommerce.
  • Compatibility: requires at least WC 2.1.x,

1.1.1

1.1.0

  • Added option to include shipping cost in fee calculation
  • Fixed issue where malformed amounts where sent to external payment services in WC 2.1.6

1.0.2

  • Fixed an issue where Pay4Pay options did not show up after saving checkout settings in WC 2.1.0
  • Updated turkish translation (Thanks a lot!)

1.0.1

  • Fix plugin URL

1.0.0

  • Initial release

Requires: 3.5 or higher
Compatible up to: 4.1.4
Last Updated: 2015-3-4
Active Installs: 2,000+

Ratings

5 out of 5 stars

Support

2 of 15 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
0,1,0 100,1,1
50,2,1
100,1,1
100,1,1