Plugin Directory

Balanced Payments for WooCommerce

A gateway for the WooCommerce eCommerce plugin to allow using Balanced Payments to take payments.

Where can I get support?

Support will be provided in the WordPress.org support forum.

Requires: 3.5 or higher
Compatible up to: 3.8.11
Last Updated: 2014-2-10
Active Installs: 20+


0 out of 5 stars


Got something to say? Need help?


Not enough data

0 people say it works.
0 people say it's broken.

100,1,1 100,1,1
100,1,1 100,1,1