Plugin Directory

Widget Twitter

The Widget Twitter plugin lets you to fully integrate your WordPress site with your Twitter account.

Thank you for your interest in Widget Twitter.

Minimum requirements.

  • WordPress 3.0+
  • PHP 5.x
  • MySQL 5.x

Perform a new installation

After downloading the ZIP file,

  1. Log in to the administrator panel.
  2. Go to Plugins Add > New > Upload.
  3. Click Choose file (Browse) and select the downloaded zip file.
    For Mac Users
    Go to your Downloads folder and locate the folder with the plugin. Right-click on the folder and select Compress. Now you have a newly created .zip file which can be installed as described here.
  4. Click Install Now button.
  5. Click Activate Plugin button for activating the plugin.

If any problem occurs, please contact us at info@web-dorado.com.

Requires: 3.0 or higher
Compatible up to: 4.3.1
Last Updated: 3 months ago
Active Installs: 7,000+


5 out of 5 stars


Got something to say? Need help?


Not enough data

0 people say it works.
0 people say it's broken.