Plugin Directory

WordPress Charts and Graphs Lite

A simple and quite powerful WordPress chart plugin to create, manage and embed interactive charts into your WordPress posts and pages.

= 1.7.1= * Fixed grid lines error links

= 1.7.0= * Fixed responsive issues * Fixed issues with zero margin values * Fixed import issue

= 1.6.6= * Fixed charts resizing on tabbed content

= 1.6.5= * Fixed responsive issue * Fixed no axis text color for line and bar charts


  • Fixed security issue when importing charts
  • Removed pointer for the pro version
  • Fixed charts import from media library
  • Added support to show legend on the left side


  • Added support for 3 more chart types
  • Fixed issue with charts not saving


  • Added export for charts
  • Enable default value for focus target. Fixed issue with hover which was not working on some machines.


  • Added free search text over graphs


  • Added step2 and 3 into step 1


  • Fixed bug with from web button


  • Added support for live editor
  • Added support for importing data from other charts
  • Added filter for chart settings
  • Fixed bug when zero was not working on the charts

  • Implemented ability to edit horizontal and vertical axis number format for bar and column charts

  • Added ability to pass a class for chart wrapper div
  • Added proper label for custom post type

  • Fixed issue with download_url function which not exists at front end
  • Added functionality which prevents direct access to the plugin folder


  • Fixed remote CSV uploading issue when allow_url_fopen option is disabled in php.ini
  • Replaced flattr image on widget and added donate link to plugin meta data
  • Added notification message at library page when allow_url_fopen option is disabled

  • Removed CSV parser escape constant to prevent warnings which appears when PHP 5.2.x or less is used


  • Fixed issue which prevents the plugin working on SSL backend
  • Fixed issue with CSV file uploading in IE and other browsers
  • Fixed issue with empty series, which appears due to leading space in a source file
  • Added ability to define custom delimiter, enclosure and escape variables for CSV parsing


  • Implemented aggregation target and selection mode options for candlestick chart
  • Implemented focus target and data opacity for columnar chars
  • Implemented data opacity and interpolate nulls settings for line chart
  • Implemented ability to edit tooltip settings
  • Implemented new settings for linear charts like selection mode and aggregation target
  • Implemented area and point opacity settings for area chart
  • Implemented new settings for pie chart like pie hole, start angle and slice offset
  • Implemented ability to select a color for chart title and legend items
  • Fixed number formatting settings for linear charts, from now it works only for axis labels
  • Reworked general settings section by moving title and font settings into separate groups

  • Replaced links to github wiki

  • Added Flattr button


  • Implemented ability to set number and date formatters
  • Implemented ability to select transparent background for a chart
  • Fixed JS bugs which appear when post type editor support is disabled
  • Fixed issue with NULL values for numeric series
  • Fixed invalid charts rendering at "Add Media" library
  • Fixed compatibility issue with another Google API related plugins
  • Added "rate the plugin" box


  • Implemented minor grid lines settings.
  • Implemented view window settings.
  • Horizontal and vertical axes settings were split into separate groups.


  • Bug with float values has been fixed.


  • Issue with "fseek warning" for Google Spreadsheet document source, was fixed.


  • Compatibility issues with WordPress version 3.6 has been fixed.


  • Active type tab in the charts library was fixed.
  • Library styles were updated.


  • Auto population was added for remote CSV file source.
  • Ability to hook chart series and data was implemented.
  • Ability to upload CSV files from web was implemented.


  • The bug with CSV file uploading was fixed.


  • The first version of the plugin was implemented.

Requires: 3.5 or higher
Compatible up to: 4.6.1
Last Updated: 1 week ago
Active Installs: 10,000+


4.5 out of 5 stars


2 of 11 support threads in the last two months have been marked resolved.

Got something to say? Need help?


Not enough data

0 people say it works.
0 people say it's broken.

100,1,1 100,1,1 100,1,1 100,1,1
100,1,1 100,1,1 100,1,1 100,1,1
100,1,1 100,1,1
50,2,1 100,4,4 100,3,3
100,1,1 100,1,1 100,1,1 100,1,1 100,5,5 100,2,2
0,1,0 100,1,1 67,3,2
100,1,1 100,1,1 0,1,0