WordPress.org

Plugin Directory

Use Admin Password

Allow privileged users to allow into less-priviliged users' accounts

1.2.3 - 20/May/2016

1.2.2 - 14/Jan/2016

  • Fix logic error since 1.2.0 that prevented login to users by admins to accounts of users with unrecognised roles

1.2.1 - 7/Dec/2015

  • Add filter allowing site owners to deploy with custom roles

1.2.0 - 30/Nov/2015

  • Add feature allowing the administrator to permit non-admin users to log into accounts at a lower level using their password
  • Code tidy-up and modernisation
  • Fix quick-link to settings page, which was not showing
  • Improve efficiency - if a match has been found, then stop processing
  • Provide a filter to allow developers to over-ride a positive result for specific cases

1.1.0 - 30/Nov/2015

  • Withdrawn release; you should upgrade to 1.2.0 immediately if you managed to catch it in the minutes it was available and you were using the newly added feature to allow non-admins to login to lower-levels. 1.1.0 had a security defect, allowing privileged users who were allowed to do this to also log in at a higher role.

1.0.3 - 19/Aug/2013

  • Prevent SQL error that occurred in 1.0.2

1.0.2 - 08/Jun/2013

  • Much faster now on sites with many users

1.0.1 - 15/May/2013

  • Correct references to use-admin-password (was imported into WordPress plugins directory as use-administrator-password, and I did not notice until now)

1.0 - 12/Jan/2012

  • First version

Requires: 3.3 or higher
Compatible up to: 4.6.1
Last Updated: 2 months ago
Active Installs: 1,000+

Ratings

5 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

1 person says it works.
0 people say it's broken.

100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1 100,1,1 100,1,1
100,1,1
100,1,1
100,1,1