WordPress.org

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

Tweet Images

A replacement for TwitPic, yFrog, etc, for posting images from Twitter clients to your blog. Creates a post per image.

0.9

  • BUGFIX: Stop refreshing rewrite rules on every request

0.8

  • BUGFIX: Fixes posting from Tweetbot (which didn't like the XML declaration for some reason… go figure)

0.71

  • CLARIFICATION: Places a notice in the admin area if you don't have pretty permalinks enabled.

0.7

  • BUGFIX: App started throwing "Error: Could not post image" message. (Now using response XML containing pretty much only the MEDIAURL element; i.e. no longer using a response as close to the TwitPic API v2 Upload method as I can get.)
  • New filter on post data before inserting it
  • New filter on tag taxonomy name before setting the terms
  • Changed filter name to wpti_update_post_data from wpti_post_data

0.6

  • Fix security hole whereby the "allow uploaded tweet images from this user" option wasn't being respected
  • Set the author ID properly
  • Inherit the post_status for the attachment from the post
  • Add a filter to allow alteration of the Tweet Image post content
  • Link to fullsize image
  • Flag to try and get around a freaky race condition
  • Posts definitely initially created in draft status
  • Added a test script

0.5

  • Allow the admin to specify which category the Tweet Image is posted to by simply checking a box

0.4

  • Version bump
  • Don't show on user profile unless this user can publish posts
  • Use home_url for the API endpoint, not site_url
  • More consistent text in admin notice
  • New translations file

0.3

  • Now you can set a specific Bit.ly account to shorten the links to your Tweet Image posts
  • Sets the post format to "image"

0.2

  • Added some security
  • Better installation instructions
  • Check more things before uploading an image

0.1

  • The initial release

Requires: 3.0 or higher
Compatible up to: 3.4.2
Last Updated: 2012-10-23
Active Installs: 100+

Ratings

0 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1 100,1,1
100,1,1
100,1,1
100,1,1