WordPress.org

Plugin Directory

Total Security

Checks your WordPress installation and provides detailed reporting on discovered vulnerabilities, anything suspicious and how to fix them.

  • 3.4.3

    • IMPROVED - Compatibility with WordPress 4.6
  • 3.4.2

    • FIX - Security issues
  • 3.4.1

    • IMPROVED - Compatibility with WordPress 4.5.3
    • FIX - Persistent cross-site scripting (XSS) vulnerability
    • FIX - Settings change vulnerability
  • 3.4

    • NEW - New Test: SSL Logins and SSL Admin Access
    • IMPROVED - Performance Improvements
    • IMPROVED - Removal of Obsolete Tests
  • 3.3.7

    • IMPROVED - Compatibility with WordPress 4.5.2
  • 3.3.6

    • IMPROVED - Compatibility with WordPress 4.5.1
  • 3.3.5

    • IMPROVED - Compatibility with WordPress 4.5
  • 3.3.4

    • IMPROVED - Compatibility with WordPress 4.4.2
  • 3.3.3

    • IMPROVED - Compatibility with WordPress 4.4.1
  • 3.3.2

    • IMPROVED - Compatibility with WordPress 4.4
  • 3.3.1

    • IMPROVED - Compatibility with WordPress 4.3.1
  • 3.3

    • IMPROVED - Compatibility with WordPress 4.3
  • 3.2.7

    • IMPROVED - Compatibility with WordPress 4.2.3
  • 3.2.6

    • IMPROVED - Compatibility with WordPress 4.2.2
  • 3.2.5

    • IMPROVED - Compatibility with WordPress 4.2
  • 3.2.4

    • FIX - File System: error in jQuery
  • 3.2.3

    • IMPROVED - Compatibility with WordPress 4.1.1
  • 3.2.2

    • IMPROVED - Compatibility with WordPress 4.0
    • IMPROVED - Russian (ru) Language pack added (thanks to zerg959)
  • 3.2.1

    • Compatibility with WordPress 3.9.1
  • 3.2

    • FIX - Minor bug fixes
  • 3.1

    • NEW - Log Viewer (debug.log) - Adds a debug menu to the admin bar that shows real-time debugging information
    • FIX - strict standards error
  • 3.0.4

    • IMPROVED - Brute force dictionary: 1050 Most Common Passwords
    • IMPROVED - Table Database Info: colored list
  • 3.0.3

    • NEW - Navigation Tabs
    • IMPROVED - Minor interface tweaks
  • 3.0.2

    • Compatibility with WordPress 3.9
    • Cosmetic fixes
  • 3.0.1

    • Compatibility with WordPress 3.8.2
  • 3.0

    • New: Add Bookmarklets "Password Hash"
    • Improved: Error 404 Log
    • Cosmetic fixes
  • 2.9.9

    • Error 404 Log: Performance improvements
  • 2.9.8.1

    • Cosmetic fixes
  • 2.9.8

    • Compatibility with WordPress 3.8.1
  • 2.9.7

    • Compatibility with WordPress 3.8
  • 2.9.6

    • Compatibility with WordPress 3.7.1
  • 2.9.5

    • Compatibility with WordPress 3.7
  • 2.9.4

    • Fixing: wpdb::escape Deprecated Function
    • "Secure Hidden Login" and "Dangerous PHP Functions" change of risk status
    • Add Spanish (es_ES) translation by Juan Pablo Población Paredes
  • 2.9.3

    • Compatibility with WordPress 3.6.1
  • 2.9.2

    • Compatibility with WordPress 3.6
  • 2.9.1

    • Compatibility with WordPress 3.5.2
  • 2.9

    • Performance improvements
    • Minor interface tweaks
  • 2.8.1

    • Performance improvements
    • Minor bug fixes
  • 2.8

    • Add new feature: Secure Hidden Login
    • Cosmetic fixes
  • 2.7

    • Add new feature: Error 404 Log
    • Cosmetic fixes
  • 2.6.351

    • Performance improvements
  • 2.5.351

    • Performance improvements
  • 2.4.351

    • Minor bug fixes
  • 2.3.351

    • Compatibility with WordPress 3.5.1
  • 2.3.350

  • 2.2.350

    • Performance improvements
    • Detect .cpl and .db
    • Cosmetic fixes
  • 2.1.350

    • Add German (de_DE) translation by Silvio Paschke
  • 2.0.350

    • Compatibility with WordPress 3.5
  • 2.0.342

    • Add new feature: File System
    • Performance improvements.
  • 1.1

    • Bug Fix
  • 1.0

    • Initial release

Requires: 4.6 or higher
Compatible up to: 4.6.1
Last Updated: 1 month ago
Active Installs: 2,000+

Ratings

3.9 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1 100,1,1
100,1,1 0,1,0
100,1,1
0,1,0
0,1,0
0,1,0
100,1,1
100,1,1
50,2,1 100,1,1
100,1,1
100,1,1