WordPress.org

Plugin Directory

Toplytics

Displays the most visited posts as a widget using data from Google Analytics. Designed to be used under high-traffic or low server resources.

Installation

  1. Upload toplytics.zip to the /wp-content/plugins/ directory;
  2. Extract the toplytics.zip archive into the /wp-content/plugins/ directory;
  3. Activate the plugin through the Plugins menu in WordPress.

Alternatively, go into your WordPress dashboard and click on Plugins -> Add Plugin and search for Toplytics. Then click on Install, then on Activate Now.

Configuration step 1

In this step please register a new client application with Google. To register an application please login to your Google account and go to Google API console.

  1. Create a New Project (set a unique project name and id);

  2. Enable the Analytics API by going to APIs & auth → API → Analytics API and then click on Enable API;

  3. From the APIs → Credentials tab create an OAuth 2.0 Client ID by clicking on Create new Client ID;

  4. Select application type as Installed application;

  5. Create the Branding information for the Client ID by editing the consent screen. It's compulsory to select your e-mail addres and to set a Product name;

  6. Create the Client ID by selecting again Installed application and Other;

  7. Download the JSON file with the API credentials (Auth Config file);

  8. Upload this file in the plugin Settings page and click on Upload Auth Config File.

Configuration step 2

In this step please connect to your Google Analytics Account.

  1. Click the Get Authorization Key button from the plugin's settings page and you will be redirected to google.com;

  2. After logging in you need to agree that the newly created app will access your Analytics data. After that you get a key;

  3. Then come back to the plugin settings page and use the key in the Authorization Key field. Click on Get Analytics Profiles button, select the profile for your current site and click on Connect.

Usage

Connect your plugin with Google Analytics Account from the Settings page (Settings -> Toplytics); Use the Toplytics widget from the Appearance -> Widgets page;

Requires: 3.9 or higher
Compatible up to: 4.1.5
Last Updated: 2015-4-18
Active Installs: 80+

Ratings

5 out of 5 stars

Support

0 of 1 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.