WordPress.org

Plugin Directory

Toplytics

Displays the most visited posts as a widget using data from Google Analytics. Designed to be used under high-traffic or low server resources.

3.0

This is a major update and you need to re-authenticate with Google Analytics for the plugin to work!

  • Google Analytics API v3.0 is being used from now on
  • major code refactoring
  • removed realtime template - the JS code can now be used directly in toplytics-template.php file
  • removed filters and actions filters: toplytics_ga_api_url_$name toplytics_ga_api_result_xml_$name toplytics_ga_api_result_simplexml_$name action: action toplytics_options_general_page
  • removed debug page
  • added new filters in order to get more information about how the plugin works toplytics_disconnect_message toplytics_analytics_data toplytics_analytics_data_result toplytics_analytics_data_allresults toplytics_rel_path toplytics_convert_data_url toplytics_convert_data_to_posts toplytics_json_data toplytics_json_all_data
  • removed 2weeks from the data range.
  • removed Romanian translation

2.1.1

  • fixed a possible infinite loop
  • WP_DEBUG enables toplytics debug mode

2.1

  • added new filters and actions filters: toplytics_ga_api_url_$name toplytics_ga_api_result_xml_$name toplytics_ga_api_result_simplexml_$name action: action toplytics_options_general_page
  • resolved the realtime template issues
  • added toplytics debug page
  • added 2weeks┬áin the data range.

2.0

  • Implemented OAuth login method.
  • Added Display posts in real time option.
  • Fixed some display bugs.
  • Refactored and cleaned-up the entire plugin code and added some tests.
  • Simplified the template syntax.
  • The plugin settings page now resides under Settings and not Tools.
  • Added i18n support.
  • Added shortcode support.
  • Added more information and documentation into Readme.txt.

1.2.2

  • Added custom theme templates support.

1.2.1

  • Add a token to login process.

1.2

  • Added custom templates.

1.1

  • First version on WP.

Requires: 3.9 or higher
Compatible up to: 4.1.5
Last Updated: 2015-4-18
Active Installs: 80+

Ratings

5 out of 5 stars

Support

2 of 2 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.