WordPress.org

Plugin Directory

* Tags: Libersy Booking, Booking System, Appointment System * "Requires at least" is the lowest version that the plugin will work on *

By: Alembo

(0)
Last Updated: 4 years ago
436 downloads
Compatible up to: 3.1.4

RSS link for this tag.