WordPress.org

Plugin Directory

(181)
Last Updated: 6 days ago
30,000+ active installs
Compatible up to: 4.6.1

A simple but effective Calendar plugin for WordPress that allows you to manage your events and appointments and display them to the world.

By: Kieran O'Shea.

(19)
Last Updated: 1 month ago
30,000+ active installs
Compatible up to: 4.6.1
(106)
Last Updated: 22 hours ago
20,000+ active installs
Compatible up to: 4.6.1

Manage and display events, recurring events, locations and maps, widgets, RSVP, ICAL and RSS feeds, payment gateways support. SEO compatible.

By: Franky.

(66)
Last Updated: 2 weeks ago
10,000+ active installs
Compatible up to: 4.6.1

This powerful property and reservation management plugin that allows you to receive, schedule and handle your bookings easily!

By: feryaz.

(47)
Last Updated: 2 months ago
9,000+ active installs
Compatible up to: 4.5.4

Create a list with events/appointments/concerts/future happenings and show them on your site. Includes optional widget and advanced page options.

By: Arnan de Gans.

(7)
Last Updated: 9 months ago
9,000+ active installs
Compatible up to: 4.4.5
(69)
Last Updated: 2 months ago
8,000+ active installs
Compatible up to: 4.5.4

WP Calendar is an easy-to-use calendar plug-in to manage all your events with many options and a flexible usage.

By: faebu.

(10)
Last Updated: 4 years ago
7,000+ active installs
Compatible up to: 3.5.2

Easily add a Customizable Facebook Feed to WordPress Website

By: a.ankit and webriti.

(5)
Last Updated: 1 month ago
7,000+ active installs
Compatible up to: 4.6.1

Add event category background colors to The Events Calendar events.

By: Andy Fragen and Barry.

(31)
Last Updated: 4 weeks ago
6,000+ active installs
Compatible up to: 4.6.1

Makes your blog to a simple "Event Calendar"

By: .

(10)
Last Updated: 2 months ago
6,000+ active installs
Compatible up to: 4.7

Allow future-time-stamped posts to appear live on your site immediately.

By: shacker, rboren, and Andrew Nacin.

(8)
Last Updated: 4 years ago
6,000+ active installs
Compatible up to: 3.5.2

RSS link for this tag.