WordPress.org

Plugin Directory

This plugin is no longer needed. GeoDirectory is now compatible with Enfold out of the box

By: Stiofan, Paolo, and posh-john.

(0)
Last Updated: 1 year ago
10+ active installs
Compatible up to: 4.1.0

RSS link for this tag.