Plugin Directory

!This plugin hasn’t been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

Stupid Simple Google Maps

Allows for the simple embeding of Google Maps in posts.

Why did you make this plugin if there are already other map plugins with more features?

I wanted a really simple wrapper plugin for the Google Static Maps API. http://code.google.com/apis/maps/documentation/staticmaps/

Can I see this plugin in action?

Yes! I've set up a few samples here: http://simple-maps.wiffin.com/samples/

Requires: 3.1.2 or higher
Compatible up to: 3.3.2
Last Updated: 5 years ago
Active Installs: 200+


0 out of 5 stars


Got something to say? Need help?


Not enough data

0 people say it works.
0 people say it's broken.