WordPress.org

Plugin Directory

WP Simple Pay Lite for Stripe

Add high conversion Stripe checkout forms to your WordPress site and start accepting payments in minutes.

Where's your plugin documentation?

Find our docs at wpsimplepay.com/docs

What are the system requirements?

SSL is required on live checkout pages, and we recommend staying current with both PHP and WP for security reasons and PCI-DSS compliance. See system requirements.

Can I get notified by email of new releases?

Subscribe here to be notified by email of major features or updates.

How do I contribute to WP Simple Pay Lite?

We'd love your help! Here's a few things you can do:

Requires: 4.2 or higher
Compatible up to: 4.6.1
Last Updated: 2 weeks ago
Active Installs: 7,000+

Ratings

4.8 out of 5 stars

Support

3 of 4 support threads in the last two months have been marked resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,2,2 100,1,1 100,1,1
100,1,1
100,1,1
100,3,3 50,2,1 100,1,1 100,1,1 50,2,1
100,1,1 100,1,1
100,1,1 100,1,1 100,1,1 100,1,1
100,1,1 100,1,1
100,2,2
100,1,1 100,1,1 100,1,1 100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,2,2
100,2,2 100,1,1