WordPress.org

Plugin Directory

Smart Image Loader

Smart Image Loader is a fire-and-forget priority and lazy loader for image sources. Can be a huge performance boost especially for one pagers.

0.4.2

  • removed file reference causing an invalid request

0.4.1

  • fixed visible detection
  • test with WordPress 4.2

0.4.0

  • fixed some rather serious issues
  • fixed js strict error in unminified file
  • exposing sil_refresh() before document ready
  • added more events! document.sil_load, document.sil_load_visible, document.sil_load_all

0.3.9

  • fixed bug where some images would not load on older android versions (2.x)
  • fixed issue where images would load too late when no absolute width and height was given and refresh on scroll was off

0.3.8

  • fixed images not being loaded when js would ignore no-js class

0.3.7

  • fixed error "Cannot redeclare file_get_html()" caused by other plugin already including simple_html_dom

0.3.6

  • fixed noscript view

0.3.5

  • adressed php warning caused by mt_rand

0.3.4

  • force data refresh for every source being inserted to adress img tags without proper sizes set causing a reflow

0.3.3

  • switched from class to data attribute due to a php dom parser bug

0.3.2

  • fixed a bug where images inserted via [caption] shortcode were being ignored
  • fixed bug where enhanced accuracy would always be on
  • removed overflow/offset checking for now because it was buggy anyway

0.3.1

  • added fancy tag word

0.3.0

  • enhanced accuracy option (checking actual visibility in addition to viewport relative position)
  • splitted refresh option into resize and scroll event
  • performance tweaks
  • tested with WordPress 4.0

0.2.3

  • using title instead of alt attribute for the sake of w3c conformity

0.2.2

  • switched to css transform for the rubberbanding effect emulation
  • more accurate image load handling

0.2.1

  • first release

Requires: 3.8.3 or higher
Compatible up to: 4.2.2
Last Updated: 2015-6-19
Active Installs: 200+

Ratings

5 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.