WordPress.org

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

Skinner

The Skinner plugin adds skin selection and editing to WordPress for Skinner compatible themes.

Creating Skins

To create a skin for a theme:

  1. Select the theme you would like to skin.
  2. Select 'Skins' on the presentation menu.
  3. Click on the 'Create Skin' button (down the bottom).
  4. Enter a name for your skin and click on the 'Create Skin' button.
  5. Your skin has been created. Click on the edit link.
  6. Edit your skin.
  7. When you are done, go back to the 'Skins' page and activate your skin.
  8. If the theme has a skin archive, go to it and let them know that you have created a new skin for the theme.

Release Notes

  • 0.1.4
    • Fixed fatal error when using the Default theme.
    • Upgraded to WordPress 2.3
  • 0.1.3
    • Fixed defect in getting options from the presentation toolkit is used.
  • 0.1.2
    • Fixed defect in styles sent to Real WYSIWG when the presentation toolkit is used. If you are using the presentation toolkit, please upgrade to 0.0.9.
  • 0.1.1
  • 0.1.0
    • Skinner now supports all themes. Themes without any skins will have a 'Default' skin to represent the theme's unskinned look.
    • Skinner now supports enabled and disabled skins. This allows you to control which skins are displayed in the skin switcher.
    • Skinner can now create skins. Activate your favourite theme, go the skins page and click on 'Create Skin'. Skinner will create the required directories and files for you.
  • 0.0.5
  • 0.0.4
    • Added support for old WordPress 2.0 installations
  • 0.0.3
    • Added BeNice support.
    • Removed nonce generation and referrer checking as it was not working. Will re-introduce later.
  • 0.0.2
    • Fixed some validation issues.
    • Fixed order of style sheet includes.
  • 0.0.1
    • Fixed output of the footer in the skin selector
    • The 'Get More Skins' title is no longer displayed if a skins archive is not specified
  • 0.0.0
    • Initial release

Requires: 2.3 or higher
Compatible up to: 2.3
Last Updated: 2007-10-23
Active Installs: 200+

Ratings

0 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

0,1,0