WordPress.org

Plugin Directory

Simple Subscribe

Simple Subscribe is the subscribe plugin you have been waiting for. It's simple to use, yet powerful, bulletproof and developers friendly. Automa

Requires: 3.3 or higher
Compatible up to: 4.1.5
Last Updated: 2015-3-22
Active Installs: 10,000+

Ratings

3.4 out of 5 stars

Support

0 of 12 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
1 person says it's broken.

0,1,0
100,1,1
100,1,1
100,1,1
0,3,0 0,1,0 100,1,1
67,3,2
100,1,1
50,2,1
0,2,0
0,1,0