WordPress.org

Plugin Directory

SEO Friend Link

SEO Friend Link

Requires: 2.8 or higher
Compatible up to: 3.9.8
Last Updated: 2014-5-5
Active Installs: 50+

Ratings

0 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

0,1,0