WordPress.org

Plugin Directory

SendGrid

Send emails throught SendGrid from your WordPress installation using SMTP or API integration.

  1. sendgrid-email-delivery-simplified screenshot 1

    Go to Admin Panel, section Plugins and activate the SendGrid plugin. If you want to send emails through SMTP you need to install also the 'Swift Mailer' plugin.

  2. sendgrid-email-delivery-simplified screenshot 2

    After activation "Settings" link will appear.

  3. sendgrid-email-delivery-simplified screenshot 3

    Go to settings page and provide your SendGrid credentials by choosing the authentication method which default is Api Key. On this page you can set also the default "Name", "Sending Address" and "Reply Address".

  4. sendgrid-email-delivery-simplified screenshot 4

    If you want to use your username and password for authentication, switch to Username&Password authentication method.

  5. sendgrid-email-delivery-simplified screenshot 5

    If you provide valid credentials, a form which can be used to send test emails will appear. Here you can test the plugin sending some emails.

  6. sendgrid-email-delivery-simplified screenshot 6

    Header provided in the send test email form.

  7. sendgrid-email-delivery-simplified screenshot 7

    If you click in the right corner from the top of the page on the "Help" button, a popup window with more information will appear.

  8. sendgrid-email-delivery-simplified screenshot 8

    Select the time interval for which you want to see SendGrid statistics and charts.

  9. sendgrid-email-delivery-simplified screenshot 9

    Now you are able to configure port number when using SMTP method.

  10. sendgrid-email-delivery-simplified screenshot 10

    You are able to configure what template to use for sending emails.

  11. sendgrid-email-delivery-simplified screenshot 11

    You are able to configure categories for which you would like to see your stats.

  12. sendgrid-email-delivery-simplified screenshot 12

    You can use substitutions for emails.

Requires: 3.3 or higher
Compatible up to: 4.4.3
Last Updated: 1 month ago
Active Installs: 20,000+

Ratings

4.6 out of 5 stars

Support

3 of 12 support threads in the last two months have been marked resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1 100,1,1
100,1,1
50,2,1
100,1,1
0,1,0
100,1,1
100,1,1
0,1,0 100,1,1
0,1,0 100,2,2