WordPress.org

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

Script Compressor

This plugin compresses javascript files and css files.

1.7.1

  • Fixed IE conditional comment bug.
  • Fixed regex bug.

1.7

  • Added @import compression.
  • Added a new function "Remove cache files".

1.6.3

  • Added some document about the deactivation.

1.6.2

  • Fixed Javascript position bug.

1.6.1

  • Added the auto-compression of theme scripts.

1.6

  • Added a new option "Exclude Javascripts".
  • Added a new option "Output Position".

1.5.1

  • WordPress2.7 support.

1.5

  • Addied a new option "Position of Javascripts".

1.4.4

  • Fixed a bug about the condition of CSS compression.

1.4.3

  • Fixed a bug about .htaccess.
  • Added a .htaccess permission check.

1.4.2

  • Fixed a bug CSS compression cannot be deactivated.
  • Added a permission check message.

1.4.1

  • Fixed a bug admin css files breaking.

1.4

  • Added a new CSS compression method.
  • Added a Gzip option.
  • Changed the output charset into that of WP.

1.3.1

  • Maked external Javascripts not picked up.
  • Some bug fixs.

1.3

  • Maked .htaccess in this plugin unnecessary.

1.2

  • Fixed a bug that URL with parameters breaks output.

1.1.1

  • Added CSS compression condition.

1.1

  • Added a selecting charaset function.
  • Improved Javascript regex.

1.0

  • Initial release.

Requires: 2.5 or higher
Compatible up to: 2.8.4
Last Updated: 2009-8-17
Active Installs: 700+

Ratings

0 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
100,1,1
100,1,1
100,1,1