WordPress.org

Plugin Directory

ScrapeBreaker

A combination of frame-breaker and scraper protection. Protect your website content from both frames and server-side scraping techniques.

1.3.4

released 04/22/15

  • Increased minimum required WordPress version to 3.8.
  • Added an .htaccess file to the scrapebreaker directory to control browser access to certain files.
  • Made various minor code improvements.

1.3.3

released 04/11/15

  • Added an uninstall function that completely uninstalls the plugin and removes all options, data, and traces of its existence when it is deleted through the dashboard.
  • Added a fix to prevent network activation when used in multisite, and added network admin notice to explain. The plugin can be used in multisite just fine, but will need to be activated individually per site for now. Once we can get time to adapt the plugin to multisite more specifically, we can remove this restriction.

1.3.2

released 03/17/15

  • Fixed an issue with URLs containing fragments ("#") that were incorrectly redirecting to the non-fragment version. This was fixed by modifying the JavaScript redirect to match the main part of the URL instead of doing an exact match for the full URL.

1.3.1

released 03/06/15

  • Fixed a minor bug.
  • Made various code improvements.

1.3

released 01/19/15

  • Increased minimum required WordPress version to 3.7.
  • Minor update to translation files.
  • Added recommended partners to settings page.

1.2

released 12/18/14

  • Prepared the plugin for internationalization and localization, and created .pot file for translation.
  • Added Serbian Translation (sr_RS). Thank you to Ogi Djuraskovic of First Site Guide for doing the Serbian translation.
  • Increased minimum required WordPress version to 3.6.
  • Minor code improvements.

1.1

released 09/06/14

  • Added a Settings page in the Dashboard.
  • Added an option to only use the JavaScript Frame Breaker (redirect) and not use the X-Frame-Options HTTP header.

1.0.1.4

released 04/28/14

  • Fixed a bug that caused an error message on certain server configurations.

1.0.1.3

released 04/13/14

  • Added additional security checks.

1.0.1.2

released 04/03/14

  • Minor code improvement.

1.0.1.1

released 03/16/14

  • Improved the implementation and removed deprecated code.

1.0.1

released 03/15/14

  • Added X-Frame-Options to HTTP headers for increased protection against framing and clickjacking.

1.0

released 03/10/14

  • Initial release.

Requires: 3.8 or higher
Compatible up to: 4.2.2
Last Updated: 2015-5-25
Active Installs: 800+

Ratings

4.6 out of 5 stars

Support

2 of 2 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

1 person says it works.
0 people say it's broken.

100,1,1 100,1,1 100,1,1 100,1,1 100,1,1 100,1,1
100,1,1 100,1,1 100,1,1 100,1,1 100,1,1 100,1,1 100,1,1 100,1,1 100,1,1
100,1,1 100,1,1 100,1,1 100,2,2 100,1,1 100,1,1 100,1,1 100,1,1 100,1,1
100,1,1 100,1,1 100,1,1 100,1,1 100,1,1
100,1,1 100,1,1 100,1,1 100,1,1 100,1,1 100,1,1 100,1,1 100,1,1 100,2,2
100,2,2 100,1,1 100,1,1 100,1,1 100,1,1 100,1,1 100,1,1 100,2,2
100,1,1 100,1,1 100,1,1 100,1,1 100,1,1 100,1,1 100,1,1 100,2,2
100,2,2 100,1,1 100,1,1 100,1,1 100,2,2
100,2,2
100,2,2
100,1,1 100,1,1 100,1,1 100,2,2 100,1,1 100,1,1 100,1,1 100,4,4
100,1,1 100,1,1 100,2,2 100,1,1 100,1,1 100,1,1 100,4,4
100,4,4
100,4,4
100,4,4
100,1,1 100,2,2 100,2,2 100,1,1 100,1,1 100,1,1 100,4,4
100,2,2 100,2,2 100,1,1 100,1,1 100,4,4
100,4,4
100,4,4
100,4,4
100,1,1
100,4,4
100,4,4
100,1,1