WordPress.org

Plugin Directory

!This plugin hasn’t been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

RiverCraft

RiverCraft permet d'unir votre serveur Minecraft et votre site/blog WordPress à l'aide de JSONAPI.

  • Vous devez tout d'abord installer le plugin JSONAPI dans le dossier Plugin de votre serveur CraftBukkit.
  • Ensuite réactulaiser ou redémarrer votre serveur.
    Un nouveau dossier au nom de JSONAPI devrai apparaître dans le dossier Plugin.
  • Ouvrez le fichier config.yml qui s'y trouve. Vous devriez voir :
                method-whitelist:   
                    - getPlayerLimit
                    - dynmap.getPort
                options:
                    stream_pusher:
                        max_queue_age: 30
                        max_queue_length: 500
                    startup-delay: 2000
                    port: 20059
                    ip-whitelist: []
                    log-to-console: true
                    log-to-file: 'false
                    anyone-can-use-calladmin: true
                    use-new-api: false
            
  • Modifiez "20059" avec le port demandé au préalable à votre hébergeur.
  • Ouvrez le fichier user.yml qui s'y trouve.Vous devriez voir :
  •             users:
                    users1:
                        username: usernameGoeshere
                        password: passwordGoesHere
                        groups:
                        - full_control
            
  • Modifiez "usernameGoeshere" avec un nom d'utilisateur.
  • Modifiez "passwordGoesHere" avec un mot de passe.
  • Installez RiverCraft, si ce n'est pas déjà fait sur votre site/blog WordPress.
  • Allez dans le nouveau menu Rivecraft qui se trouve dans votre BackOffice.
  • Insérez les informations demandés
  • Allez dans le Apparence>Widgets et activez le widget. Les champs sont déjà remplis. Vous pouvez éventuellement modifier ces champs pour afficher un autre serveur.
  • Requires: 3.0 or higher
    Compatible up to: 3.6.1
    Last Updated: 3 years ago
    Active Installs: 20+

    Ratings

    5 out of 5 stars

    Support

    Got something to say? Need help?

    Compatibility

    +
    =
    Not enough data

    0 people say it works.
    0 people say it's broken.

    100,1,1 100,1,1
    100,1,1
    100,1,1