WordPress.org

Plugin Directory

Test out the new Plugin Directory and let us know what you think.

Reusable Text Blocks

Create reusable pieces of content that you can insert into themes, posts, pages & widgets.

1.5.1

  • Fixed no attribute error

1.5

  • Fixed PHP 7 Warnings
  • Added slug="" parameter when added from Add Block button (helps you know which shortcode block is which)
  • Text Blocks will only show if Published
  • Variables. You can add {{player}} to your text block and then pass in 'player' to the shortcode: [text-blocks id="1" player="Hal Gatewood"]

1.4.10

  • Added filter wpml_object_id

1.4.9

  • WP_Widget construct changed

1.4.8

  • Fixed plugin not adhering to the language needed. Thanks @elvi992

1.4.7

  • Added ‘id’ to text_blocks_shortcode_html filter
  • Fixed widget checkboxes with on
  • Added quotes around plain=1

1.4.6

  • Added .pot file, translation ready
  • Removed custom post messages
  • Added filter: 'text_blocks_post_type_args'
  • Added Media Button to quickly add shortcode to WP Text Editor
  • 'show_text_block' now has third parameter that passes all shortcode parameters to the text block, for example: [text-blocks id="198" location="okc"]
  • Create custom templates: text-blocks-{$id}.php, or pass template="homepage" in your shortcode for text-blocks-homepage.php
  • New checkbox in widget to hide the title

1.4.5

  • Enabled revisions
  • Added filter: 'text_blocks_show_text_block_id'
  • Tested on WordPress 4.1

1.4.4

  • Fix for error if no content found

1.4.3

  • Moved init into plugins_loaded
  • WordPresss 3.8 testing and icon

1.4.2

  • Post thumbnail support added.

1.4.1

  • Added second parameter to keep out the_content filter and display exactly what is in the content.

1.4

  • Display by slug (post_name) or id
  • Slug class added to widget so you can target text-blocks easier with CSS

1.3

  • Added ability to set wpautop in widget
  • Also added filter to target widget code: 'text_blocks_widget_html'

1.2

  • Bug in widget select box (Thanks Shaun Forsyth)

1.1

  • Small bug fixes

1.0

  • Initial load of the plugin.

Requires: 3.5 or higher
Compatible up to: 4.7.2
Last Updated: 6 months ago
Active Installs: 9,000+

Ratings

4.9 out of 5 stars

Support

0 of 2 support threads in the last two months have been marked resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

1 person says it works.
0 people say it's broken.

100,1,1
100,1,1
100,2,2
100,1,1
100,1,1
100,1,1
100,2,2
0,1,0
100,2,2
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1 100,1,1
100,1,1
100,1,1
100,1,1