WordPress.org

Plugin Directory

Recent Posts Widget Extended

Provides flexible and advanced recent posts. Display it via shortcode or widget with thumbnails, post excerpt, taxonomy and more.

0.9.9.6 - June 9, 2016

  • Updated languages
  • Bump Requires at least to version 4.5
  • Support selective refresh
  • Updated widget sanitization

0.9.9.4 - Nov 09, 2015

  • Sanitize before and after element for better security

0.9.9.3 - 19/09/2015

  • Change text-domain to matches the plugin slug
  • Add: Exclude post option

0.9.9.2 - 13/08/2015

  • Add: Brazilian portuguese translation. Props Gil Barbara
  • Add: Option to show modification date. Props kurt-hectic
  • Add: Option to show comment count. Props Oliver Larsen
  • Improve: Add validation to the Order and Orderby option before saving the widget.

0.9.9.1 - 12/07/2015

  • Prepare to support WordPress 4.3
  • Update: Limit the number of tags and categories displayed in the widget

0.9.9 - 29/11/2014

  • Fix: for "cssID" attribute in shortcodes. Props Ikart
  • Fix: Thumbnail fallback uses get_the_post_thumbnail
  • Add: rpwe-img to the thumbnail.
  • Add: css class option.
  • Improve: Move use styles default option to above the custom css. I'm sorry for the incosistency.
  • Update: Language

0.9.8 - 26/11/2014

  • Fix: Compatibility issue with Get The Image plugin/extension.
  • Fix: Issue with html or text before and after recent posts, now it allow all HTML tags.

0.9.7 - 13/09/2014

  • Add: Relative date option eg: 4 days ago. Props George Venios
  • Add: Featured Video Plus plugin support.
  • Add: Hide widget if no posts exist.
  • Add: Fallback to the image attachment if no image url exist in the resizer script.
  • Fix: Compatibility issue if the user theme use the same code library(Aqua Resizer) and causing blank screen.

Requires: 4.5 or higher
Compatible up to: 4.5.3
Last Updated: 2 weeks ago
Active Installs: 100,000+

Ratings

4.8 out of 5 stars

Support

2 of 35 support threads in the last two months have been marked resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
100,2,2 100,1,1 100,1,1 100,1,1
100,1,1 100,2,2 100,1,1
100,1,1 100,1,1
100,1,1 100,1,1
100,1,1
100,1,1
100,1,1
83,6,5
100,1,1
0,1,0
100,1,1 100,2,2
100,2,2 100,2,2
0,2,0
0,1,0 63,8,5
75,4,3 50,2,1
78,9,7
89,9,8
100,1,1
100,5,5 100,1,1
67,3,2
100,1,1 100,2,2
100,2,2 100,1,1
80,5,4 100,2,2
60,5,3
100,2,2
100,5,5
50,2,1
25,4,1 100,1,1