WordPress.org

Plugin Directory

Read and Understood

Records acknowledgements that specific users have read specific postings (or not).

1.6

  • Added functionality originally intended for Version 1.4
  • Changed format of exported CSV file. It now has one column per post.
  • Optionally, allows export of CSV in "old" format (option to be retired 11/1/2015)
  • Puts date/time in cell if the user name (row) has read the post (column).
  • Optionally, exports WordPress Users even if they had not acknowledged a post in the time frame.
  • Reordered functions, leaning towards alphabetical.

1.5

  • Temporarily backs out Version 1.4
  • Created new version to do so in case authorse had automatically upgraded to broken V 1.4

1.4

  • Broken: Users reported "Headers already sent ..." error
  • Changed format of exported CSV file. It now has one column per post.
  • Optionally, allows export of CSV in "old" format (option to be retired 11/1/2015)
  • Puts date/time in cell if the user name (row) has read the post (column).
  • Optionally, exports WordPress Users even if they had not acknowledged a post in the time frame.
  • Reordered functions, leaning towards alphabetical.

1.3

  • Looks for POST table using WPDB prefix, rather than assumed "wp_" (thanks to jwbowers for reporting this)
  • Also, uninstall.php is now used.

1.2

  • Corrected instance of _( with __( as reported in Support forum

1.1

  • Corrected display of number of records to be purged on confirmation button
  • Corrected number of records purged message
  • Replaced incomplete copy of jquery.js with 1.7.2
  • Turned off WP_DEBUG for production.
  • Created css/images to house jquery-ui images
  • Moved rnu_uninstall outside of class
  • Exploits, but does not require JavaScript.
  • Moved JavaScript to external file in /js folder
  • First draft of test plan included in /test folder
  • Ready for Translation, including JavaScript files

1.0

  • Corrected the description of the login required checkbox by removing "not"
  • Placed many more string literals in __(...) for future translation

0.2

  • Removed remote reference to jquery-ui.css and included local copy

Requires: 3.0 or higher
Compatible up to: 4.0.5
Last Updated: 2014-10-30
Active Installs: 20+

Ratings

4.8 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.