WordPress.org

Plugin Directory

Test out the new Plugin Directory and let us know what you think.

Prezi Embedder

This plugin allows the user to quickly & easily embed a Prezi in WordPress site by directly implementing the published iframe embed code.

Requires: 2.5 or higher
Compatible up to: 4.4.5
Last Updated: 12 months ago
Active Installs: 2,000+

Ratings

5 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
100,1,1 100,1,1 100,1,1 100,1,1 100,1,1
100,1,1
100,1,1
100,1,1