WordPress.org

Plugin Directory

Test out the new Plugin Directory and let us know what you think.

Post Access Controller

Enhances the Post "Visibility" options within the edit post page to allow specific users or groups of users access to the post.

1.1.1

  • Fixed bug in classes/db.php that broke in PHP < 5.3.

1.1.0

  • Finished refactoring and included the "roles" option for setting access controls on a given post.

0.9.9

  • Refactored to be more maintainable and better setup for future feature requests and less bug/patch fixes. All existing configurations should continue to work without any changes needed.

0.9.5

  • Fixed bugs happening in PHP 5.3 with array shorthand syntax

0.9.4

  • Added option to control which groups public users can add themselves to
  • Fixed a few bugs found while developing new public user controls
  • Cleaned up code

0.9.3

  • Fixed PHP error that caused User Group maintenance page to break starting in WP 4.0

0.9.2

  • Adjusted what is displayed to users that don't have access to a page that get to the URL representing that page. It was showing a 404 because WordPress said there was nothing on that page for them but now it will show the Access Denied header and the indicated No Access message.

0.9.1

  • Added interim option to allow the WP Core post visibility option if enabled in the Post Access Controller settings page

0.9.0

  • Major change in how data is stored, WILL BREAK existing implementations and require either re-entry of access control groups and access control user selections or a custom conversion script. Please make support request if you would like a conversion script.
  • Bug fix to remove posts from the listing that user does not have access to
  • Created custom post type and converted from custom database tables to use the core wp_posts and related meta data
  • Cleaned up admin pages again to really feel like it operates like WP Core
  • Adjusted necessary pieces to make it work within the WP Plugin Library

0.5.0

  • Rewrote admin pages to use WP classes so the feel of the pages matched the rest of core

0.1.0

  • Initial version with custom database tables and non-WP looking admin pages

Requires: 3.0.1 or higher
Compatible up to: 4.5.4
Last Updated: 6 months ago
Active Installs: 100+

Ratings

4.3 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
1 person says it's broken.

100,1,1
0,1,0
0,1,0
0,1,0 0,2,0 0,2,0
0,1,0
0,1,0
0,1,0
100,1,1
0,1,0