WordPress.org

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

PDO (SQLite) For WordPress

This 'plugin' enables WP to use databases supported by PHP's PDO abstraction layer. Currently, mysql and sqlite drivers are provided.

What databases are supported?

Currently the basic layer supports any database that is supported by PDO.

  • MS SQL Server (PDO) Microsoft SQL Server and Sybase Functions (PDO_DBLIB)
  • Firebird/Interbase (PDO) Firebird/Interbase Functions (PDO_FIREBIRD)
  • IBM (PDO) IBM Functions (PDO_IBM)
  • Informix (PDO) Informix Functions (PDO_INFORMIX)
  • MySQL (PDO) MySQL Functions (PDO_MYSQL)
  • Oracle (PDO) Oracle Functions (PDO_OCI)
  • ODBC and DB2 (PDO) ODBC and DB2 Functions (PDO_ODBC)
  • PostgreSQL (PDO) PostgreSQL Functions (PDO_PGSQL)
  • SQLite (PDO) SQLite Functions (PDO_SQLITE)

Note that through the PDO_ODBC extension, all ODBC supported databases are also supported, subject to drivers being available

HOWEVER each database needs its own driver and currently the only drivers written for this plugin are for

  • sqlite and
  • mysql

The database does not install. Why?

the main reason for this is permissions. The php process on your server needs to have permissions to create files and directories. Please contact me by leaving a comment at rathercurious.net if this is affecting you.

Requires: 2.3.0 or higher
Compatible up to: 2.9.2
Last Updated: 2010-1-14
Active Installs: Less than 10

Ratings

5 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

0,1,0
100,1,1 100,1,1
100,1,1
0,1,0 100,2,2
100,4,4
25,4,1
38,13,5
100,1,1
0,2,0
29,7,2
100,2,2
100,1,1
67,6,4
50,4,2
0,1,0
0,1,0
0,2,0