WordPress.org

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

PayPal Framework

PayPal integration framework and admin interface as well as IPN listener.

1.0.11

  • Don't verify SSL on validation calls - too many people with out of date CAs

1.0.10

  • Replace instance of _() with __() - Props Ken Bass

1.0.9

  • Use admin-ajax for listener
  • Add sslverify filter - props @evansolomon

1.0.8

  • Fix missing quotes

1.0.7

  • Lots of code cleanup, some requiring WordPress 2.8+
  • Better help
  • Make translatable

1.0.6

  • Fixed a bug that throws a warning for certain requests when in debugging mode. Props Ken Bass kbass@kenbass.com

1.0.5

  • Fixed a bug introduced in 1.0.4 that affected certain debug messages when not using the sandbox

1.0.4

  • Debug E-Mails for live requests now get an obfuscated credit card number (ACCT) as well as EXPDATE and CVV2
  • The IPN listener only throws a transaction-specific action if a txt_type is given in the message

1.0.3

  • IPN Message validations now work even if there are apostophes (slashes are stripped)
  • You can now have multiple debug E-Mail addresses (comma separated)

1.0.2

  • Added a / to the IPN URL so that PayPal doesn't complain that it's invalid
  • Fixed a couple debug messages to send the proper URL used
  • Added a more general "paypal-ipn" action that can be used to catch and process all IPN message
  • Moved add_action calls inside the __construct

1.0.1

  • Added sendToExpressCheckout method for sending users to PayPal to finish up Express Checkout Payments
  • Changed hashCall to use the WordPress WP_Http class
  • Changed makeNVP to a public method
  • Updated makeNVP to use http_build_query
  • Switched to using wp_remote_post rather than specifying POST and using wp_remote_request

1.0.0

  • Original version released to wordpress.org repository

Requires: 2.8 or higher
Compatible up to: 3.1.4
Last Updated: 2013-4-3
Active Installs: 1,000+

Ratings

5 out of 5 stars

Support

0 of 1 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
100,1,1
100,1,1
100,1,1
100,2,2 0,1,0
100,1,1
100,1,1