Plugin Directory

!This plugin hasn’t been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

Password Protection

HTTP Basic Authentication as secondary defense for wp-admin - blocks brute force attacks. Also blocks users (bots) with No-Referrer Headers.

Active Versions

Downloads Per Day

Downloads history

Today 0
Yesterday 1
Last Week 4
All Time 1,697

Requires: 3.5.1 or higher
Compatible up to: 3.6 beta
Last Updated: 3 years ago
Active Installs: 70+


0 out of 5 stars


Got something to say? Need help?


Not enough data

0 people say it works.
0 people say it's broken.