WordPress.org

Plugin Directory

Centrora Security™

Protect your WordPress site with Centrora Security. Also recommended for multiple sites security management.

Requires: 3.7 or higher
Compatible up to: 4.1.1
Last Updated: 2015-4-13
Active Installs: 4,000+

Ratings

4.2 out of 5 stars

Support

2 of 4 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

0,1,0
100,1,1
100,2,2 67,3,2
100,2,2
0,1,0 100,4,4
100,1,1
100,1,1 100,1,1 100,3,3 100,1,1 50,2,1 100,1,1 100,1,1 100,1,1 100,1,1
100,1,1
100,2,2 100,1,1
100,1,1
100,1,1
100,1,1
100,1,1