WordPress.org

Plugin Directory

Multiple Post Thumbnails

Adds multiple post thumbnails to a post type. If you've ever wanted more than one Featured Image on a post, this plugin is for you.

After version 1.3, releases were tracked in github: https://github.com/voceconnect/multi-post-thumbnails/releases

Historical releases are below:

1.6.6

  • Fixed escaping of iframe url

1.3

  • Don't show set as links in media screens when not in context (props prettyboymp). Add voceplatforms as an author. Updated FAQ.

1.2

  • Only enqueue admin scripts on needed pages (props johnjamesjacoby) and make sure thickbox is loaded (props prettyboymp). Add media-upload script to dependencies for post types that don't already require it (props kevinlangleyjr).

1.1

  • Update FAQ. Clean up readme. Don't yell null. Don't output link to original if there is no image.

1.0

  • Use get_the_ID() in get_the_post_thumbnail. Props helgatheviking.

0.9

  • Increment version only to attempt to get plugin versions back in sync.

0.8

  • Revert init action changes from 0.7. Fixes admin metaboxes not showing when the MultiPostThumbnails class is instantiated in an action instead of functions.php

0.7

  • Add actions/filters on init action. Should fix admin metaboxes not showing or showing out of order. props arizzitano.

0.6

  • Update get_the_post_thumbnail return filter to use format {$post_type}_{$thumb_id}_thumbnail_html which allows filtering by post type and thumbnail id which was the intent. Props gordonbrander.
  • Update plugin URL to point to Plugin Directory

0.5

  • Update readme to check for MultiPostThumbnails class before calling.

0.4

  • Added: optional argument $link_to_original to *_the_post_thumbnails template tags. Thanks to gfors for the suggestion.
  • Fixed: PHP warning in media manager due to non-existent object

0.3

  • Fixed: when displaying the insert link in the media library, check the post_type so it only shows for the registered type.

0.2

  • Update docs and screenshots. Update tested through to 3.0 release.

0.1

  • Initial release.

Requires: 2.9.2 or higher
Compatible up to: 4.1.5
Last Updated: 2015-4-24
Active Installs: 50,000+

Ratings

5 out of 5 stars

Support

0 of 4 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

0,1,0
100,3,3 71,7,5
75,8,6 100,7,7
100,6,6
100,3,3
100,1,1 100,1,1
50,8,4 83,6,5
100,1,1
100,3,3
100,3,3
73,11,8 80,5,4 100,1,1 100,4,4
57,7,4
100,12,12 100,8,8 100,1,1
50,2,1 100,3,3
100,3,3
88,8,7 80,5,4
100,5,5 100,1,1
80,5,4 100,4,4 100,1,1
100,4,4 83,6,5 80,5,4
100,5,5
100,2,2
100,5,5
100,1,1
67,6,4
100,1,1
100,1,1
100,2,2
100,5,5 100,1,1
0,1,0
50,2,1 100,1,1 100,1,1
75,4,3 100,1,1
100,1,1 50,2,1