Plugin Directory

!This plugin hasn’t been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

Modern-I Contact Form

Moderni contact form plugin gives a WP most flexible and usable contact form.WP-admin can use either captcha or simple contact form.

Requires: 2.9 or higher
Compatible up to: 2.9 to 3.4.1
Last Updated: 2012-10-12
Active Installs: 40+


0 out of 5 stars


Got something to say? Need help?


Not enough data

0 people say it works.
0 people say it's broken.