WordPress.org

Plugin Directory

MailPoet Gravity Forms Add-on

Adds a new field for you to allow your visitors to subscriber to your MailPoet newsletters.

2.0.4 - 19/08/2014

  • Fixed white screen of death when upgrading Gravity Forms
  • Fixed users are forced to subscribe when multiselect is disabled

2.0.3 - 17/05/2014

  • Fixed version check generating a fatal error depending on the version of Gravity Form used on the site
  • Fixed issue with lists selection when generating a form with a MailPoet field (Thx Danilo Petrozzi for reporting the issue :) )

2.0.2 - 24/03/2014

  • ADDED - Plugin Update Information - Now you can read what changes have been made on the plugins page when an update is available.
  • TESTED - WordPress 3.9 beta 2 and works.
  • UPDATED - POT file.

2.0.1 - 24/03/2014

  • CORRECTED - Issue with screen id used for settings page, prevented from loading if in any other language but English.
  • CORRECTED - If function 'mailpoet_lists' is already defined, then don't load again.
  • REMOVED - Translation of the brand name 'MailPoet' only.
  • UPDATED - POT file.

2.0.0 - 20/03/2014

  • IMPROVED - Code structure to help correct some of the core functions so it responds better.
  • IMPROVED - Javascript in form editor to identify if the field is enabling multi-list selection or not.
  • CORRECTED - Now the plugin checks if Gravity Forms is installed and activated first.
  • CORRECTED - Display of checkboxs, lists only the selected lists from the form editor if enabled multi-selection.
  • CORRECTED - When single checkbox is in use, it subscribes the users to the lists selected from the settings page.
  • CORRECTED - MailPoet field no longer stops the rest of the form from loading if MailPoet is not activated.
  • ADDED - Check if Gravity Forms is not the minimum version required, the user is asked to update it.
  • ADDED - Settings page under Gravity Forms to configure correctly the single checkbox option used in the form.
  • ADDED - Portuguese (Brazil) language.
  • UPDATED - POT file.

1.0.0 - 02/02/2014

  • Initial Release.

Requires: 3.7.1 or higher
Compatible up to: 3.9.5
Last Updated: 2014-8-19
Active Installs: 1,000+

Ratings

5 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,2,2 100,1,1