WordPress.org

Plugin Directory

Mad Mimi Signup Forms

Add the Mad Mimi webform to your WordPress site! Easy to set up, the Mad Mimi plugin allows your site visitors to subscribe to your email lists.

Requires: 3.8 or higher
Compatible up to: 4.5.3
Last Updated: 1 month ago
Active Installs: 2,000+

Ratings

5 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,2,2
100,1,1