WordPress.org

Plugin Directory

Lock Pages

Lock Pages prevents specified pages (or all pages) from having their slug, parent, status or password edited, or from being deleted, by non-administra

0.2.3

  • Removed PHP 4 constructor

0.2.2

  • Added locking of page template

0.2.1

  • Fixed clash with Simple Page Ordering plugin

0.2

  • Updated check for page edit screen for WP 3
  • Improved removal of Quick Edit functionality
  • Removed edit permalink elements, slug meta box, parent drop-down, status and password fields for locked pages
  • Changed initialization to use admin_init
  • Improved refusal of delete capability for locked pages
  • Added locking for page status and password protection
  • Added JavaScript and changed inclusion of CSS to use wp_enqueue_style
  • Created POT file for translations
  • Added Spanish translations (thanks to Javier G√≥mez Pose!)
  • Many coding style improvements
  • Removed unused properties $thispluginurl and $thispluginpath, introduced use of plugins_url
  • Fixed handling of $args in lock_deletion to account for different user_has_caps contexts
  • Improved form security with esc_attr

0.1.6

  • Refined check in lockParent so now uploads stay attached to a page even if you edit the attachment details after uploading.

0.1.5

  • Added (hopefully temporary) blocking of Quick Edit functionality on pages that are locked for user who can't edit locked page elements.

0.1.4

  • Added a check in lockParent to make sure it's not handling a file upload. Without this, the lock was preventing files being attached to a locked page.

0.1.3

0.1.2

  • Added prevention of deletion of locked pages.
  • Added "Lock" column and icon on Edit Pages list.
  • Streamlined permission checking.

0.1.1

  • Fixed New Page meta box so the page lock checkbox is unchecked by default.
  • Changed 'capability' parameter for add_options_page() to match the capability setting in the plugin, i.e. only users with the capability to edit "locked" pages can change the plugin settings.

0.1

  • First release.

Requires: 3.0 or higher
Compatible up to: 4.1.4
Last Updated: 2014-12-16
Active Installs: 2,000+

Ratings

4 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
100,1,1 100,1,1
0,1.844674407371E+19,3
50,2,1
100,1,1
0,1,0
100,1,1
100,1,1 100,2,2
0,1,0
100,1,1
100,1,1
0,1,0
100,1,1
100,1,1
100,1,1