WordPress.org

Ready to get started?Download WordPress

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

Kiva.org Loans Widget

Displays rotating entrepreneurs the blogger has invested in publically. Links back to Kiva.

What is Kiva.org?

A micro-lending site applications. http://kiva.org

Will it show private loans?

No, it will only show your public Kiva loans.

How do I change the look of the Kiva Loans Widget?

The style sheet is in the plugin folder at /wp-content/plugins/kiva-widget/style.css

What if I get the json_decode error?

If you get the following error:

Fatal error: Call to undefined function: json_decode() in wp-content/plugins/kivaorg-widget/kiva.php

This error means that you do not have PHP JSON.s support installed on your server. JSON support became a part of the PHP core in PHP 5.2.0. The best way to handle this error is to upgrade your PHP to the newest stable available version. Most Linux distributions will have packages for upgrading. On Windows, you can go to the PHP Downloads page. For more information, check out the PHP JSON Manual.

What if I get the Permission Denied error

Warning: fopen( wp-content/plugins/kivaorg-widget/cache/kiva_cache_1241553368.txt) [function.fopen]: failed to open stream: Permission denied

This error means that improper permissions are set within the Kiva widget directory on your server. The directory .cache. within the widget must be writable by your server.s web users. You can fix this problem by changing the ownership of the directory .cache. to the web user. Most likely one of the following command will work, if performed within the plugin directory ( wp-content/plugins ):

chown www-data:www-data kivaorg-widget/cache

or

chmod 777 /kivaorg-widget/cache

Why are the loan images not displaying?

Kiva has moved it's images to a different location. Some images are uneffected, while others will be missing in the plugin. Version 2.1 of this widget now handles these moved images. Please upgrade to the newest version of the Kiva WordPress Widget

Requires: 2.8 or higher
Compatible up to: 2.8.5
Last Updated: 2009-11-4
Active Installs: 60+

Ratings

0 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.