WordPress.org

Plugin Directory

Test out the new Plugin Directory and let us know what you think.

IMPress for IDX Broker

Over 600 IDX/MLS feeds serviced. The #1 IDX/MLS solution just got even better!

What is IDX?

Internet Data Exchange, or IDX, is a type of data feed provided by your MLS. This data feed typically (but not always) mirrors the data available on your MLS's website. IMPress for IDX Broker connects to this data feed automatically, maps the necessary fields, and then adds forms, scripts, etc, giving you a way to add html links and widgets to your website(s).

How does IDX Broker connect with the IMPress for IDX Broker plugin?

An IDX Broker API key (separate purchase required) provides the IMPress plugin with access to preset Widgets, search forms, an xml sitemap file, and much more.

How is the IDX content hosted/updated?

IDX Broker hosts your IDX data on a subdomain (e.g., search.yoursite.com). This allows IDX Broker to update quickly, and offers a lightning-fast, co-brandable search engine for real estate professionals and WordPress designers regardless of the quality of the hosting solution that you are using for your website. Low quality, inexpensive hosting solutions often cannot process or manage the amount of data provided by an IDX feed.

Why is IDX Broker hosted in the cloud?

All IDX feeds are hosted on high-quality Amazon AWS servers with multiple layers of redundancy. This ensures that even if your hosted website (mysite.com) goes down, your IDX Broker pages (search.mysite.com) will almost always be available to visitors.

What is a Wrapper and why does IDX Broker need to create a Wrapper page on my WordPress site?

The IMPress plugin offers an easy one-button option to create a Wrapper for IDX pages. This wrapper page is then used to magically update your IDX pages every hour, or whenever you modify/refresh your IDX Broker plugin page. This means less work for you or your website developer.

Do I need an IDX Broker Lite or Platinum account in order to use this plugin?

Yes. All IDX feeds require approval from a local board or MLS. If you (or your client if a designer) are not a member of a local board or MLS, or the MLS does not provide an IDX data feed, then you will be unable to add IMPress for IDX Broker plugin functionality to your WordPress site.

Is my service area available?

Read more about our MLS coverage. Note that some MLS's may charge you a separate fee for access to your IDX feed.

Does IDX Broker require a long-term contract like other IDX services?

No. IDX Broker requires a month-to-month agreement only.

What is the pricing for IDX Broker services?

There are three monthly account levels - Agent ($39.99+), Team ($69.99+), and Office ($98.99+). Read more about pricing.

What can I expect if I decide to get my IDX feed through IDX Broker?

When you sign up for a new account our MLS team will send you a Docusign email (or PDF). Simply add your signature to the Docusign file or PDF in order to proceed. If you are not a Principal Broker, and have provided us with your Broker name and contact information, we will then forward the same paperwork to your Broker for approval. Once we receive the paperwork from your Broker, we will send to the MLS for data approval. MLS approval can take anywhere from 3-10 days. Once approved, we will activate your account, integrate your site's design into IDX pages, and send you IDX Broker login credentials so that you can use this plugin to add links and Widgets to your site or blog.

How many blogs/websites can I integrate with IDX Broker?

Features provided by this Plugin - Widgets, links, and custom links may be placed onto any WordPress website or blog. The reason for this is because all Widgets, links, and custom links point back to the original IDX-approved website. Note that using iframes to display this same content is prohibited and may result in account termination due to MLS rules.

What are Other Requirements for this Plugin?

This plugin requires a PHP version higher than 5.4. For security reasons, we recommend updating to the latest stable version of PHP your web host provides. We also recommend using the latest production version of WordPress. See this article for more information.

Requires: 3.7 or higher
Compatible up to: 4.7.1
Last Updated: 1 month ago
Active Installs: 8,000+

Ratings

3.5 out of 5 stars

Support

0 of 3 support threads in the last two months have been marked resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

1 person says it works.
0 people say it's broken.

100,1,1 100,2,2
100,1,1
100,2,2
100,1,1
100,1,1
100,1,1
100,1,1 100,1,1 100,1,1 100,1,1
100,1,1 100,1,1
100,1,1
0,1,0
100,1,1
100,2,2
100,1,1 100,1,1 100,2,2 100,1,1 100,1,1
100,1,1
100,1,1 100,2,2
0,1,0 100,1,1
100,2,2
100,1,1
100,1,1
100,1,1