WordPress.org

Plugin Directory

Hide My Site

Choose a single password to protect your entire wordpress site from the public and search engines

Requires: 2.9 or higher
Compatible up to: 4.0.1
Last Updated: 2014-10-27
Active Installs: 10,000+

Ratings

4.5 out of 5 stars

Support

0 of 2 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

1 person says it works.
0 people say it's broken.

100,1,1 100,1,1
100,1,1
100,1,1
100,2,2
100,1,1
100,1,1
100,1,1
100,1,1
100,2,2
100,1,1