WordPress.org

Plugin Directory

Test out the new Plugin Directory and let us know what you think.

gee Search Plus, improved WordPress search

Extends WordPress search engine to taxonomies, custom fields and media, sorts results by relevance or date, and more. Simple and clean!

1.4.4

  • GOMO replaces geeThemes brand.
  • Tested against WP version 4.6.1

1.4.3

  • Fixed: PHP notices
  • Tested against WP version 4.3.1 - all fine!

1.4.2

  • Fixed: Convert specific stopwords to lowercase on save
  • Fixed: Issue when searching on Tags (post_tag taxonomy) - conflict with plugins that inject specific post_types on query_vars without checking if 'any' is already selected.

1.4.1

  • Tested up to WP 4.0
  • Fix division by zero warning

1.4.0

  • Extend search to media

1.3.1

  • fix pagination on search results

1.3.0

  • Full review for WP 3.7
  • Order by relevance or by date
  • Allow OR and AND query type
  • Highlight class instead of inline styles
  • New plugin hooks for better control
  • Merge stopwords mechanism with WordPress new native stopwords mechanism
  • Prepared for i18n

1.2.0

  • Re-named from gSearch to gee Search ( affected functions, hooks and classes )
  • New relevance engine
  • Corrected wp_title bug

1.1.8

  • Load frontend script on footer
  • Default highlight area div#content

1.1.7

  • Admin: Replaced color picker - using WP default
  • Admin: New setting 'Highlight allowed areas' uses valid jQuery selectors
  • jQuery scripts enqueued differently on frontend thus solving Jetpack conflicts

1.1.6

  • Revision and testing for WP 3.6

1.1.5

  • Optimized queries to reduce needed memory

1.1.4

  • Less strict when searching custom fields (LIKE compare)

1.1.3

  • Corrects issue regarding spaces in the middle of searched terms

1.1.2

  • Corrects issue regarding spaces on beginning and end of the search sentence.

1.1.1

  • Minor corrections on jshighlight script

1.1.0

  • New features: custom fields search & highlight searched terms.
  • Includes two new js: jscolor plugin and jshighlight

1.0.0

  • Initial release.
  • No multisite compatibility. More to come shortly.

Requires: 3.5 or higher
Compatible up to: 4.6.1
Last Updated: 1 week ago
Active Installs: 1,000+

Ratings

4.7 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1 100,1,1 100,1,1 100,1,1 100,1,1 100,2,2 100,1,1
100,2,2 100,1,1
50,2,1 100,1,1 100,2,2
100,1,1 100,1,1 100,1,1
100,1,1
100,1,1 100,1,1
100,1,1 100,1,1
100,1,1
100,1,1 100,1,1
100,1,1
100,1,1
100,1,1