WordPress.org

Plugin Directory

Better HubSpot for Gravity Forms

Easily integrate your Gravity Forms with HubSpot forms! Match up field-for-field so you can harness the power of HubSpot.

Is my Hub ID required?

Yes. Your Hub ID is required to connect to oAuth, and for including the Analytics Tracking javascript, if you check the box for us to provide it ("HubSpot for WordPress", their official plugin, already includes analytics)

If you are going to connect via API Key, and not include the tracking script, we do not need your Hub ID.

Where do I find my HubSpot Hub ID?

After logging into your account on HubSpot.com, your Hub ID can be found with the product version at the bottom of your HubSpot Dashboard in the footer.

Where do I get a HubSpot API Key?

Fill out the form on the following link, and click "Get My API Key": https://app.hubspot.com/keys/get -- You will receive an email containing your API Key, once approved.

Why do I keep losing my oAuth connection?

HubSpot's oAuth API requires a new token roughly every 8 hours. If no one visits the website for more than an 8 hours period, this script can't get a newer token, and has to be re-validated. We are still working on a way to resolve this. However, at this point it will likely require a server CRON being set up.

We highly recommend you use oAuth: it's more secure, and you can safely (and easily) revoke access at any time through HubSpot.

My "Date" field in HubSpot isn't getting the correct date?

This was due to HubSpot expecting a time in milliseconds, and not actually sending us a code saying that it failed for that reason. As such, we have added support for Field Types in v1.1.4 ... After updating, if you go edit your HubSpot Connections (via Forms > HubSpot), edit the existing one, and click "save" ... it will now support Date, and properly carry over.

We currently only support "date" and "string" types from HubSpot, but we'll work on adding more in the future.

Requires: 3.5 or higher
Compatible up to: 4.1.5
Last Updated: 2015-6-9
Active Installs: 300+

Ratings

5 out of 5 stars

Support

2 of 2 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.