Plugin Directory

Gravity Forms Paystation (3 Party Hosted)

Integrates Gravity Forms with the Paystation 3 party hosted payment gateway allowing end-users to purchase goods and services via Gravity Forms.

1.4.3 [2015-09-17]

  • Added do_action('gfpaystation_post_payment', $lead, $form) after payment success and do_action('gfpaystation_post_payment_fail', $lead, $form) after payment failed so devs can hook in to these events.
  • Fixed non-display of the payment information when looking at form entry details (due to Gravity Gravity forms change).
  • Tested against WordPress 4.4 and Gravity Forms 1.9.13

1.4.2 [2015-04-22]

  • Something screwy happened with SVN when trying to add and commit 1.4.1 so had to create new 1.4.2 directory. No changed from previous version.

1.4.1 [2015-04-22]

  • Tested with WordPress 4.1.2 and WordPress 4.2 beta and Gravity Forms 1.9.6. No problems detected.

1.4.0 [2014-09-09]

  • Tested with WordPress 4.0 and Gravity Forms 1.8.13 and eveything looks fine.
  • Added a new feature allowing payments to go in to different Paystation accounts for merchants with multiple Paystation accounts.

1.3.1 [2014-04-29]

  • Tested with WordPress 3.9 and Gravity Forms 1.8.7. All good!

1.3.0 [2014-03-06]

  • As requested, made it so that the payment datetime is saved as GMT / UTC time rather than New Zealand date and time so it will display correctly no matter the timezone set in the WordPress settings.

1.2.1 [2014-02-27]

  • Fixed bug where if a Failure URL was specified in the settings then the user would always be directed there even if the payment was successful.

1.2.0 [2014-01-23]

  • Fixed issues (due to changes in Gravity Forms version 1.7) with the notifications.
  • Fixed nonce handling issue in options admin page.
  • Implimented fix to ensure that WordPress SEO does not break operation of this plugin.

1.1.0 [2013-10-16]

  • Fixed a couple of bugs that prevented test mode being turned off.
  • Corrected grammar error in the readme.txt

1.0.0 [2013-03-11]

  • Original Version.

Requires: 3.3 or higher
Compatible up to: 4.4
Last Updated: 2015-9-17
Active Installs: 60+


5 out of 5 stars


Got something to say? Need help?


Not enough data

0 people say it works.
0 people say it's broken.