This plugin hasn’t been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

Graceless Degradation

Description

Graceless Degradation checks to see if the current browser is MSIE 6. If it’s not, it does nothing. If it is, it injects CSS and JavaScript into the page that:

  • Puts Comic Sans fonts everywhere!
  • Makes emphasis tags (bold, italic, strong, and underline) blink! Even though IE doesn’t support the tag!
  • Turns

tags into animated rainbows! * Finds “mailto:” links and tacks on animated mailbox graphics!

Plugin’s Official Site

http://drench.github.com/graceless-degradation/

Screenshots

  • The same page Gracelessly Degraded (IE6 with Windows XP)
  • The normal page under a 'tasteful' browser (Chrome with OS X)

FAQ

What about IE 5 (or IE 4, 3, 2, 1…)?

This plugin only “supports” IE 6, for various reasons. The main one is I don’t have earlier versions of IE to test. Also, I would have to convert things like document.getElementById() into document.all or whatever people used to do to support IE 4. If you’re game, this plugin is open source. Fork it and patch it.

Changelog

0.11

Initial release

Contributors & Developers

This is open source software. The following people have contributed to this plugin.

Browse the code